php-buildで複数バージョンのPHP-FPMを用意する


(2016/8/9)PHP7やHomebrewの現状に合わせるため細かい点を修正しました。


ついにPHP 5.5.0がリリースされましたね!これに関連して、php-buildを使ってPHP 5.3/5.4/5.5の3バージョンのPHP-FPM環境を用意する方法を紹介します。


この記事は「phpenv + php-build を使って 5.3 と 5.4 を共存させつつ php-fpm を使う - 肉とご飯と甘いもの @ sotarok」のアップデートのような内容になっています。ありがとうsotarok!

PHP-FPMとは

PHP-FPMはPHPのSAPI実装の一つで、単体で動作するアプリケーションサーバです。Apacheなしで動くので、気軽に扱えたりします。あまりうまく説明できないので、詳しくはPHP-FPM本家サイトあたりを見てください。

phpenv+php-buildのセットアップ

僕はphp-buildをphpenvプラグインとして使っていますので、この環境を作りましょう。まずphpenvをインストールします。

続きを読む